Problems with Molly

This is a blog post about the things that have not quite gone right with our Molly. We are just getting started here, but wanted to keep track of issues along the way.

1st Eng Sys alarm

Saturday, May 26, 2018. California/Arizona Border ~3,659 miles

It was hot, above 40ºC, and I was stuck in a long line of traffic waiting for inspection at the State of California Food & Agriculture Dept: Inspection Station, when Molly decided to light up with the first engine alarm. It was amber, meaning, get to FUSO when you can.

I pulled over at the first opportunity and rang FUSO. They wanted to tow me, but that was not really an option, as I had no way to get back to San Francisco. So, we jointly decided to stop the engine to see if it would reset and restart. I was worried it would not start again. But it did, and no alarm, so off I went.

At the time I did not know how to read the error codes. So not sure what the reported issue was.

2nd Eng Sys alarm

Wednesday, July 4, 2018. San Jose, 4,179 miles.

Planned to take Molly out for the 4th of July vacation day. But plans changed quickly after a Red Eng Sys alarm was displayed. The error code was SPN=3701 and FMI=-2, which is a bit meaningless to me. According to the manual this means “The value measured by component ‘Differential pressure sensor of diesel particular filter’ is too high.”. Also a little meaningless.

One of the possible failure modes is “Filter regeneration was not successful or not possible.”. This makes sense, as Molly was stuck in highway traffic while trying to do a DPF regeneraiton. Molly entered half power mode.

A visit to the local FUSO service center did not help. They found a different alarm, being “The coolant temperature is implausible”, which is an amber alarm. I guess this is related to the 1st Eng Sys alarm, and might not have reset. The FUSO service center removed the thermostat, everything looked ok, reset the code, did a regen, upgraded the software and a drive test. Not highly conclusive. Maybe the software upgrade would help, at least the regen issue.

3rd Sys Eng alarm

Monday, September 3, 2018. Near Tahoe on Highway 80. 5,850 miles.

Returning from Tahoe, and caught in heavy highway traffic for the third time, and our 3rd Sys Eng alarm, amber this time. The error code was SPN=520644 and FMI=31, the implausible coolant issue again. The thing is, the coolant was not high. Cycling the eng engine off and on cleared the issue. I am starting to suspect that this issue occurs after fast highway speeds followed by stop and go traffic. Will see if this happens again.